Programming:Perl:Dist::Zilla hidden feature: minimum bundle version requirement

From Knowledge base
Revision as of 07:19, 13 March 2018 by Celogeek (talk | contribs)
(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)
Jump to: navigation, search

Dist::Zilla is a great tool to create Perl distribution.

You can also create PluginBundle that includes everything you usually use in your package.

You will usually add and remove packages in your PluginBundle, and you want that people who help you develop and release your Perl distribution to use the right version of your bundle.

Here a hidden feature of the PluginBundle @Filter that allow doing this :

[@Filter]
-bundle = @MyBundle
-version = MINIMUM_VERSION

The command $ dzil listdeps ask now to run the command $ dzil authordeps until it got the right version of the bundle.



Share your opinion